Remington 700 Rifle Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
OK, so I adjusted my Sendero's trigger exactly as per these instructions (which match other ones I've found):

http://www.snipercountry.com/Articles/Remingtontriggers.asp

Unfortunately, it did not work. After adjusting it (which seemed to work well) it now releases/fires every time I close the bolt. The only way I can keep it from doing this is by engaging the safety, and then whenever I disengage the safety, the pins still drops. I've tried moving each of the 3 screws independently, together, you name it and nothing changes it. It seems like something inside the trigger is in the wrong position, as I can hear a small "rattle" now inside the trigger that was not there before. What could have fallen out of place?

If anyone has suggestions (other than replacing with a Timney - I'd like to see if this one will work first) I'd appreciate them.

Oh, and I've worked on triggers on several of my rifles and shotguns previously, having taken them apart and adjusted them. So, I'm not really a newbie at it. If I can disassemble and reassemble my Ruger Mk II pistol, much less a Quadrajet, I should be able to do this.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
So I went to work on this again today, and after adjusting the 3 screws and analyzing the trigger many times, I decided to remove the safety to get a better look at the trigger. And, this is what I found:







Is this worth getting repaired?

Or am I better off at this point swapping it out?



Thanks.
 
1 - 4 of 4 Posts
Top